导航
导航

记一次dva升级后的bug

前言:去年的时候针对公司老项目(dva环境)进行了一次优化升级,升级后没出现啥问题,因为疫情的关系,导致一直在家办公,最近针对老项目又加了个需求,用自己的电脑从Gogs上down下来npm install之后运行就报错了。

安装完依赖npm start的时候,就开始报如下的错误:

1
2
3
Failed to compile
./node_modules/history/esm/history.js
Module not found: Can't resolve '@babel/runtime/helpers/esm/extends' in 'xxxx\prong-console-tenant\node_modules\history\esm'

一般删了node_modules重新安装依赖能解决80%的问题,但这次重新安装却不起作用了。于是就开始了折腾之旅了,去Google搜了一圈,找了几个解决方案尝试之后发现都不太行。

最后在Github issues里找到了解决思路:history 版本问题。

按以下步骤检查:

1、npm list history 查看history安装情况;

2、如果版本不是4.7.2,卸载history, npm un history

3、npm list history 确保history已全部删除;

4、npm install --save history@4.7.2 安装指定版本;

按照如上步骤就把这个错误解决了,运行成功。完美!

支持一下
扫一扫,支持hzzly
  • 微信扫一扫
  • 支付宝扫一扫